use strict;
my $str = '"WIRELESS CALLER" <sip:+18004001506@192.168.18.40;isup-oli=62>;tag=gK0461bc7f';
my $regex = qr/(^[A-Za-z0-9 \"]*)(\<sip:)([\+1]*8004001506)(.*\>.*)/mp;
my $subst = '\\"Company A\\" \\2\\3\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";