// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)\.(\d+)\.(\d+)").unwrap();
let string = "1.2.3
1.2.33
1.22.3
11.2.3
11.22.33
1.22.33
11.22.3
11.2.33";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}