$re = '`(\d+)\.(\d+)\.(\d+)`m';
$str = '1.2.3
1.2.33
1.22.3
11.2.3
11.22.33
1.22.33
11.22.3
11.2.33';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;