#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+)\.(\d+)\.(\d+)"
Local $sString = "1.2.3" & @CRLF & _
"1.2.33" & @CRLF & _
"1.22.3" & @CRLF & _
"11.2.3" & @CRLF & _
"" & @CRLF & _
"11.22.33" & @CRLF & _
"1.22.33" & @CRLF & _
"11.22.3" & @CRLF & _
"11.2.33"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)