const regex = new RegExp('(\\d+)\\.(\\d+)\\.(\\d+)', 'gm')
const str = `1.2.3
1.2.33
1.22.3
11.2.3
11.22.33
1.22.33
11.22.3
11.2.33`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);