# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+)\.(\d+)\.(\d+)//gm;t' <<< "1.2.3
1.2.33
1.22.3
11.2.3
11.22.33
1.22.33
11.22.3
11.2.33"