import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\.(\\d+)\\.(\\d+)";
final String string = "1.2.3\n"
+ "1.2.33\n"
+ "1.22.3\n"
+ "11.2.3\n\n"
+ "11.22.33\n"
+ "1.22.33\n"
+ "11.22.3\n"
+ "11.2.33";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}