use strict;
my $str = '1.2.3
1.2.33
1.22.3
11.2.3
11.22.33
1.22.33
11.22.3
11.2.33';
my $regex = qr`(\d+)\.(\d+)\.(\d+)`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";