# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+)\.(\d+)\.(\d+)"
test_str = ("1.2.3\n"
"1.2.33\n"
"1.22.3\n"
"11.2.3\n\n"
"11.22.33\n"
"1.22.33\n"
"11.22.3\n"
"11.2.33")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.