import Foundation
let pattern = #"(<p id="nav">)\s?(.*?)\s?(<\/p>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p id="nav">
<a href="http://tenupclp.dev/wp-login.php?action=register">Register</a> | <a href="http://tenupclp.dev/wp-login.php?action=lostpassword">Lost your password?</a>
</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1fart$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)