# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<p id="nav">)\s?(.*?)\s?(<\\/p>)/$1fart$3/g;t' <<< "<p id=\"nav\">
<a href=\"http://tenupclp.dev/wp-login.php?action=register\">Register</a> | <a href=\"http://tenupclp.dev/wp-login.php?action=lostpassword\">Lost your password?</a>
</p>"