$re = '/(<p id="nav">)\s?(.*?)\s?(<\/p>)/';
$str = '<p id="nav">
<a href="http://tenupclp.dev/wp-login.php?action=register">Register</a> | <a href="http://tenupclp.dev/wp-login.php?action=lostpassword">Lost your password?</a>
</p>';
$subst = "$1fart$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;