// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<p id="nav">)\s?(.*?)\s?(<\/p>)"#).unwrap();
let string = "<p id=\"nav\">
<a href=\"http://tenupclp.dev/wp-login.php?action=register\">Register</a> | <a href=\"http://tenupclp.dev/wp-login.php?action=lostpassword\">Lost your password?</a>
</p>";
let substitution = "$1fart$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}