using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<p id=""nav"">)\s?(.*?)\s?(<\/p>)";
string substitution = @"$1fart$3";
string input = @"<p id=""nav"">
<a href=""http://tenupclp.dev/wp-login.php?action=register"">Register</a> | <a href=""http://tenupclp.dev/wp-login.php?action=lostpassword"">Lost your password?</a>
</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}