import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<p id=\"nav\">)\\s?(.*?)\\s?(<\\/p>)";
final String string = "<p id=\"nav\">\n"
+ "<a href=\"http://tenupclp.dev/wp-login.php?action=register\">Register</a> | <a href=\"http://tenupclp.dev/wp-login.php?action=lostpassword\">Lost your password?</a>\n"
+ "</p>";
final String subst = "$1fart$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}