const regex = /(<p id="nav">)\s?(.*?)\s?(<\/p>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p id="nav">)\\s?(.*?)\\s?(<\\\/p>)', 'g')
const str = `<p id="nav">
<a href="http://tenupclp.dev/wp-login.php?action=register">Register</a> | <a href="http://tenupclp.dev/wp-login.php?action=lostpassword">Lost your password?</a>
</p>`;
const subst = `$1fart$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);