use strict;
my $str = '<p id="nav">
<a href="http://tenupclp.dev/wp-login.php?action=register">Register</a> | <a href="http://tenupclp.dev/wp-login.php?action=lostpassword">Lost your password?</a>
</p>';
my $regex = qr/(<p id="nav">)\s?(.*?)\s?(<\/p>)/p;
my $subst = '$1fart$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";