import Foundation
let pattern = #"(\d\d\d\d)-(\d\d)-(\d\d)T(\d\d:\d\d:\d\d).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2020-05-09T20:43:08+02:00"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\3.\2.\1 \4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)