use strict;
my $str = '2020-05-09T20:43:08+02:00';
my $regex = qr/(\d\d\d\d)-(\d\d)-(\d\d)T(\d\d:\d\d:\d\d).*/mp;
my $subst = '\\3.\\2.\\1 \\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";