# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d\d\d\d)-(\d\d)-(\d\d)T(\d\d:\d\d:\d\d).*/\3.\2.\1 \4/gm;t' <<< "2020-05-09T20:43:08+02:00"