# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d\d\d\d)-(\d\d)-(\d\d)T(\d\d:\d\d:\d\d).*"
test_str = "2020-05-09T20:43:08+02:00"
subst = "\\3.\\2.\\1 \\4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.