const regex = /(\d\d\d\d)-(\d\d)-(\d\d)T(\d\d:\d\d:\d\d).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d\\d\\d\\d)-(\\d\\d)-(\\d\\d)T(\\d\\d:\\d\\d:\\d\\d).*', 'gm')
const str = `2020-05-09T20:43:08+02:00`;
const subst = `\3.\2.\1 \4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);