#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d\d\d\d)-(\d\d)-(\d\d)T(\d\d:\d\d:\d\d).*"
Local $sString = "2020-05-09T20:43:08+02:00"
Local $sSubst = "\3.\2.\1 \4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)