$re = '/(\d\d\d\d)-(\d\d)-(\d\d)T(\d\d:\d\d:\d\d).*/m';
$str = '2020-05-09T20:43:08+02:00';
$subst = "\3.\2.\1 \4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;