using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d\d\d\d)-(\d\d)-(\d\d)T(\d\d:\d\d:\d\d).*";
string substitution = @"\3.\2.\1 \4";
string input = @"2020-05-09T20:43:08+02:00";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}