package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d\d\d\d)-(\d\d)-(\d\d)T(\d\d:\d\d:\d\d).*`)
var str = `2020-05-09T20:43:08+02:00`
var substitution = "\3.\2.\1 \4"
fmt.Println(re.ReplaceAllString(str, substitution))
}