// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?'line'public (?'type'\w+\??) (?'property'[A-z]+).*)$").unwrap();
let string = "public string? PropertyA { get; set; }
public string? PropertyB { get; set; }
public int? PropertyC { get; set; }";
let substitution = "/// <summary>\\n/// $property\\n/// <\\/summary>\\n$line\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}