# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?'line'public (?'type'\w+\??) (?'property'[A-z]+).*)$"
test_str = ("public string? PropertyA { get; set; }\n"
"public string? PropertyB { get; set; }\n"
"public int? PropertyC { get; set; }")
subst = "/// <summary>\\n/// $property\\n/// <\\/summary>\\n$line\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.