# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?'line'public (?'type'\w+\??) (?'property'[A-z]+).*)$/\/\/\/ <summary>\n\/\/\/ $property\n\/\/\/ <\\/summary>\n$line\n/gm;t' <<< "public string? PropertyA { get; set; }
public string? PropertyB { get; set; }
public int? PropertyC { get; set; }"