package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?'line'public (?'type'\w+\??) (?'property'[A-z]+).*)$`)
var str = `public string? PropertyA { get; set; }
public string? PropertyB { get; set; }
public int? PropertyC { get; set; }`
var substitution = "/// <summary>\n/// $property\n/// <\/summary>\n$line\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}