import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'line'public (?'type'\\w+\\??) (?'property'[A-z]+).*)$";
final String string = "public string? PropertyA { get; set; }\n"
+ "public string? PropertyB { get; set; }\n"
+ "public int? PropertyC { get; set; }";
final String subst = "/// <summary>\\n/// $property\\n/// <\\/summary>\\n$line\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}