$re = '/^(?\'line\'public (?\'type\'\w+\??) (?\'property\'[A-z]+).*)$/m';
$str = 'public string? PropertyA { get; set; }
public string? PropertyB { get; set; }
public int? PropertyC { get; set; }';
$subst = "/// <summary>\n/// $property\n/// <\/summary>\n$line\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;