use strict;
my $str = 'public string? PropertyA { get; set; }
public string? PropertyB { get; set; }
public int? PropertyC { get; set; }';
my $regex = qr/^(?'line'public (?'type'\w+\??) (?'property'[A-z]+).*)$/mp;
my $subst = '/// <summary>\\n/// $property\\n/// <\\/summary>\\n$line\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";