using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?'line'public (?'type'\w+\??) (?'property'[A-z]+).*)$";
string substitution = @"/// <summary>\n/// $property\n/// <\/summary>\n$line\n";
string input = @"public string? PropertyA { get; set; }
public string? PropertyB { get; set; }
public int? PropertyC { get; set; }";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}