re = /^(?'line'public (?'type'\w+\??) (?'property'[A-z]+).*)$/m
str = 'public string? PropertyA { get; set; }
public string? PropertyB { get; set; }
public int? PropertyC { get; set; }'
subst = '/// <summary>\\n/// $property\\n/// <\\/summary>\\n$line\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result