import Foundation
let pattern = #":values: (.*)(\n.*)*:modal_name: (.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
:values: T
:asdfasdfa
:asdf
:asdfad
:modal_name: Operational_Segment_Weekly
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3=$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)