re = /:values: (.*)(\n.*)*:modal_name: (.*)/m
str = ':values: T
:asdfasdfa
:asdf
:asdfad
:modal_name: Operational_Segment_Weekly
'
subst = '$3=$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result