#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m):values: (.*)(\n.*)*:modal_name: (.*)"
Local $sString = ":values: T" & @CRLF & _
":asdfasdfa" & @CRLF & _
":asdf" & @CRLF & _
":asdfad" & @CRLF & _
":modal_name: Operational_Segment_Weekly" & @CRLF & _
""
Local $sSubst = "$3=$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)