// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):values: (.*)(\n.*)*:modal_name: (.*)").unwrap();
let string = ":values: T
:asdfasdfa
:asdf
:asdfad
:modal_name: Operational_Segment_Weekly
";
let substitution = "$3=$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}