const regex = /:values: (.*)(\n.*)*:modal_name: (.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':values: (.*)(\\n.*)*:modal_name: (.*)', 'gm')
const str = `:values: T
:asdfasdfa
:asdf
:asdfad
:modal_name: Operational_Segment_Weekly
`;
const subst = `$3=$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);