import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":values: (.*)(\\n.*)*:modal_name: (.*)";
final String string = ":values: T\n"
+ ":asdfasdfa\n"
+ ":asdf\n"
+ ":asdfad\n"
+ ":modal_name: Operational_Segment_Weekly\n";
final String subst = "$3=$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}