$re = '/:values: (.*)(\n.*)*:modal_name: (.*)/m';
$str = ':values: T
:asdfasdfa
:asdf
:asdfad
:modal_name: Operational_Segment_Weekly
';
$subst = "$3=$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;