# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/:values: (.*)(\n.*)*:modal_name: (.*)/$3=$1/gm;t' <<< ":values: T
:asdfasdfa
:asdf
:asdfad
:modal_name: Operational_Segment_Weekly
"