using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":values: (.*)(\n.*)*:modal_name: (.*)";
string substitution = @"$3=$1";
string input = @":values: T
:asdfasdfa
:asdf
:asdfad
:modal_name: Operational_Segment_Weekly
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}