import Foundation
let pattern = #"(\d{4})-(\d{2})-(\d{2})\s(\d{2}):(\d{2}):(\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2021-10-13 00:00:00"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2/$3/$1 $4:$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)