# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{4})-(\d{2})-(\d{2})\s(\d{2}):(\d{2}):(\d{2})/$2\/$3\/$1 $4:$5/gm;t' <<< "2021-10-13 00:00:00"