// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4})-(\d{2})-(\d{2})\s(\d{2}):(\d{2}):(\d{2})").unwrap();
let string = "2021-10-13 00:00:00";
let substitution = "$2/$3/$1 $4:$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}