const regex = /(\d{4})-(\d{2})-(\d{2})\s(\d{2}):(\d{2}):(\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4})-(\\d{2})-(\\d{2})\\s(\\d{2}):(\\d{2}):(\\d{2})', 'gm')
const str = `2021-10-13 00:00:00`;
const subst = `$2/$3/$1 $4:$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);