use strict;
my $str = '2021-10-13 00:00:00';
my $regex = qr/(\d{4})-(\d{2})-(\d{2})\s(\d{2}):(\d{2}):(\d{2})/mp;
my $subst = '$2/$3/$1 $4:$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";