import Foundation
let pattern = #"(\d+)(st|nd|rd)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Liverpool to score 2 goals in 1st 90 minutes
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"nth"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)